$re = '/(?:^|\.)(?:(?!\b(?:bad|good)\b)[^.\n])*(\bgood\b)(?![^.\n]+\bbad\b)/im';
$str = 'A good example of a bad regex.
A bad example of a good regex.
A bad example. A good regex.
A good example. A bad regex.
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);