$re = '/^\b[a-z0-9 ]+\b$/m';
$str = 'a
aa
aaa
a
a
a ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);