// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)^[0-9a-f]{8}-([0-9a-f]{4}\-){3}[0-9a-f]{12}$").unwrap();
let string = "7CED1B68-9A09-437F-9EEC-F79C2F59A772
7CED1B689EECF79C2F59A77";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}