#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([A-Za-z./\-\(\=><) ]+:?\*?|^[A-Za-z./\-\(\=><)0-9 ]+:+?|^[A-Za-z0-9/\-\(]+)? *?(([0-9\*]+)(\.|\-)*([0-9\*]+)*)(( *?[0-9]+? *?\^ *?[0-9]+)*[a-zA-Z./% ]*) ?([0-9.\-= ]+)? ?(?![0-9]+)([a-zA-Z./% ]+)?$"
Local $sString = "Platelet Count : 297 10 ^ 3/c.mm150 - 450" & @CRLF & _
"Platelet Count : 297 10 ^ 3/c.mm150 - 450" & @CRLF & _
"Total T3 (Tri-iodothyronine) : 86.99 ng/dl 58 - 159" & @CRLF & _
"Bilirubin (Direct) SERUM 0.32 0 - 0.50 mg/dl" & @CRLF & _
"Total Cholesterol SERUM 180.00 0 - 200 mg/dl" & @CRLF & _
"Packed Cell Volume : 39.7 % 36.0 - 46.0" & @CRLF & _
"asd123" & @CRLF & _
"y Q P Age /Sex * 45Years / Female123asd" & @CRLF & _
"Blood Sugar Fasting PLASMA 92 70 - 105 mg/dl" & @CRLF & _
"Referred By : QUANTUM CORPORTAE HEALTH Age /Sex : 32 Years Male" & @CRLF & _
"Packed Cell Volume : 39.7 % 36.0 - 46.0" & @CRLF & _
"Platelet Count : 341 10 * 3/c.mm150 - 400" & @CRLF & _
"Uric Acid SERUM 8.42* 3.50-7.20 mg/dl" & @CRLF & _
"SERUM TOTAL CHOLESTEROL 180 mg/dl 123Desirable" & @CRLF & _
"ESR :* 22 mm / thr. 0-12" & @CRLF & _
"Haemoglobin - 12.4 gm % 12.0 - 15.0" & @CRLF & _
"Erythrocytes : 4.30 mill/c.mm 3.8 - 4.8" & @CRLF & _
"MCHC :* 31.4 g/dl 31.5 - 34.5" & @CRLF & _
"MPV :* 8.7 fl 9.0 - 13.0" & @CRLF & _
"Neutrophils - 62 % 40 - 80" & @CRLF & _
"Eosinophils 4-3 % 1-6" & @CRLF & _
"ABO And RhD Typing : A - positive" & @CRLF & _
"Poikilocytosis 5 *" & @CRLF & _
"Referred By : Quantum Corportae Health Pvt Ltd Ace Sen seme . Yeas. / Female" & @CRLF & _
"" & @CRLF & _
"^([A-Za-z./\-\(\) ]+|^[A-Za-z0-9/\-\(]+) +([0-9.\-]+) *([a-zA-Z/%1 ]*) +([0-9./\-= ]+)* *([A-Za-z/]*)" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"^([A-Za-z./\-\(\=><) ]+|^[A-Za-z0-9/\-\(]+) *([0-9.\*-]+)([a-zA-Z./% ]*) +([0-9.\-= ]+)* *([A-Za-z/]*)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")