const regex = /["'`](?:(?<=")[^"\\]*(?s:\\.[^"\\]*)*"|(?<=')[^'\\]*(?s:\\.[^'\\]*)*'|[^`]*`)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('["\'`](?:(?<=")[^"\\\\]*(?s:\\\\.[^"\\\\]*)*"|(?<=\')[^\'\\\\]*(?s:\\\\.[^\'\\\\]*)*\'|[^`]*`)', 'g')
const str = `Almost every SQL statement uses \`identifier\`s in some way to refer to a database or its constituent elements such as tables, views, columns, indexes, stored routines, triggers, or events. When you refer to elements of databases, \`identifier\`s must conform to the following rules.
Legal characters in \`identifier\`s. Unquoted \`identifier\`s may consist of latin letters a-z in any lettercase, digits 0-9, dollar, underscore, and Unicode extended characters in the range U+0080 to U+FFFF. \`Identifier\`s can start with any character that is legal in an \`identifier\`, including a digit. However, an unquoted \`identifier\` cannot consist entirely of digits because that would make it indistinguishable from a number. MySQL’s support for \`identifier\`s that begin with a number is somewhat unusual among database systems. If you use such an identifier, take particular care if it contains an 'E' or 'e' because those characters can lead to ambiguous expressions. For example, the expression 23e + 14 (with spaces surrounding the '+' sign) means column 23e plus the number 14, but what about 23e+14? Does it mean the same thing, or is it a number in scientific notation?
\`Identifier\`s can be "quoted" (delimited) within backtick characters ('\`'), which permits use of any character except a NUL byte or Unicode supplementary characters (U+10000 and up):
"string \\"string\\" string"
"string \\\\"string\\\\" string"
'string \\'string\\' string'
'string \\\\'string\\\\' string'
\`string string\`
\`string \`string\` string\`
"address" – retrns an absolute reference as plain text of the top-left cell in reference.
"col" – returns the column number of the cell in reference.
"contents" – returns the value contained in the top-left cell in reference.
"prefix" – returns a text value based on the horizontal text alignment in the cell in reference. A single quotation mark (') is used for left-aligned text, a double quotation mark (“) for right-aligned text, a carat (^) for centre-aligned text and empty for everything else.
"row" – returns the row number of the top-left cell in reference.
"type" – returns the type of data in the cell in reference. The following values are returned: "b" for a blank cell, "l" (for label) if the cell contains plain text and "v" (for value) if the cell contains any other type of data.
"width" – returns the column width in terms of the number of characters that can fit in the cell provided in reference. The number returned is determined based on the width of the zero (0) character of the default font size. Note that this is different from the cell width that Google Sheets uses elsewhere, which is defined in terms of pixels`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}