re = /\w/
str = 'abcdefghijklmnopqrstuvwxyz
ABCDEFGHIJKLMNOPQRSTUVWXYZ
0123456789
_'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end