#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\/\*(.+?)\*\/"
Local $sString = "using System.Collections;" & @CRLF & _
"using System.Collections.Generic;" & @CRLF & _
"using UnityEngine;" & @CRLF & _
"using UnityEngine.UI;" & @CRLF & _
"using TMPro;" & @CRLF & _
"using System.Text.RegularExpressions;" & @CRLF & _
"using System;" & @CRLF & _
"" & @CRLF & _
"public interface IThemeable" & @CRLF & _
"{" & @CRLF & _
"" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"public class TestScript : MonoBehaviour" & @CRLF & _
"{" & @CRLF & _
" #region Studio Style" & @CRLF & _
" class Program : IThemeable" & @CRLF & _
" {" & @CRLF & _
" static int _I = 1;" & @CRLF & _
"" & @CRLF & _
" delegate void DoSomething();" & @CRLF & _
" static DoSomething DelegateMethod = delegate { };" & @CRLF & _
"" & @CRLF & _
" /* This" & @CRLF & _
" is a multi line" & @CRLF & _
" quote" & @CRLF & _
" */" & @CRLF & _
"" & @CRLF & _
" /*single line quote*/" & @CRLF & _
"" & @CRLF & _
" /* single line quote */" & @CRLF & _
"" & @CRLF & _
" /// <summary>" & @CRLF & _
" /// The quick brown fox jumps over the lazy dog" & @CRLF & _
" /// THE QUICK BROWN FOX JUMPS OVER THE LAZY DOG" & @CRLF & _
" /// </summary>" & @CRLF & _
" static void Main(string[] args)" & @CRLF & _
" {" & @CRLF & _
" string normalStr = "The time now is approximately " + DateTime.Now;" & @CRLF & _
" Uri Illegal1Uri = new Uri("http://packmyboxwith/jugs.html?q=five-dozen&t=liquor");" & @CRLF & _
" Regex OperatorRegex = new Regex(@"\S#$", RegexOptions.IgnorePatternWhitespace);" & @CRLF & _
"" & @CRLF & _
" for (int O = 0; O < 123456789; O++)" & @CRLF & _
" {" & @CRLF & _
" _I += (O % 3) * ((O / 1) ^ 2) - 5;" & @CRLF & _
" if (!OperatorRegex.IsMatch(Illegal1Uri.ToString()))" & @CRLF & _
" {" & @CRLF & _
" // no idea what this does!?" & @CRLF & _
" Console.WriteLine(Illegal1Uri + normalStr);" & @CRLF & _
"" & @CRLF & _
" }" & @CRLF & _
" }" & @CRLF & _
" Program.DelegateMethod();" & @CRLF & _
" }" & @CRLF & _
" static int Sum(int a, int b)" & @CRLF & _
" {" & @CRLF & _
" return a + b;" & @CRLF & _
" }" & @CRLF & _
" }" & @CRLF & _
" #endregion" & @CRLF & _
"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")