$re = '/^[a-zA-Z]{2,}(?: [a-zA-Z]{2,})+$/m';
$str = 'John Phillip Paul Jones
Cher
Bond aka 007
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);