# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"((?<=^\d{1}. )|(?<=^\d{2}. )|(?<=^\d{3}. )|(?<=^\d{4}. ))([^:]*)(?=:)"
test_str = ("144. Spalding, K.L., Buchholz, B.A., Bergman, L.E., Druid, H., Frisén, J.: Forensics: e age written in teeth by nuclear tests. Nature 437(7057) (2005) 333–334\n"
"145. Lovecraft, H.P.: HP Lovecraft: Tales: Tales. Library of America (2005)\n"
"146. Duncan, R.: A survey of parallel computer architectures. Computer 23(2) (1990) 5–16\n"
"147. Santos, N., Hoshino, Y.: Global distribution of rotavirus serotypes/genotypes and its implication for the development and implementation of an effective rotavirus vaccine. Reviews in medical virology 15(1) (2005) 29–56\n"
"148. DIARRHOEA, R.: Rotavirus and other viral diarrhoeas. Bulletin of the World Health Organization 58(2) (1980) 183–198\n"
"149. Barton, T.: Power and knowledge: astrology, physiognomics, and medicine under the Roman Empire. University of Michigan Press (2002)\n"
"150. Gauquelin, M.: The cosmic clocks: From astrology to a modern science. H. Regnery Company (1967)")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.