const regex = /^(?:\d+\. )([^:,]*,[^:,]*)(?=[:,])/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:\\d+\\. )([^:,]*,[^:,]*)(?=[:,])', 'gm')
const str = `144. Spalding, K.L., Buchholz, B.A., Bergman, L.E., Druid, H., Frisén, J.: Forensics: e age written in teeth by nuclear tests. Nature 437(7057) (2005) 333–334
145. Lovecraft, H.P.: HP Lovecraft: Tales: Tales. Library of America (2005)
146. Duncan, R.: A survey of parallel computer architectures. Computer 23(2) (1990) 5–16
147. Santos, N., Hoshino, Y.: Global distribution of rotavirus serotypes/genotypes and its implication for the development and implementation of an effective rotavirus vaccine. Reviews in medical virology 15(1) (2005) 29–56
148. DIARRHOEA, R.: Rotavirus and other viral diarrhoeas. Bulletin of the World Health Organization 58(2) (1980) 183–198
149. Barton, T.: Power and knowledge: astrology, physiognomics, and medicine under the Roman Empire. University of Michigan Press (2002)
150. Gauquelin, M.: The cosmic clocks: From astrology to a modern science. H. Regnery Company (1967)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}