import re
regex = re.compile(r"(?<=\d\. )([^,]*,[^,:]*)", flags=re.MULTILINE)
test_str = ("144. Spalding, K.L., Buchholz, B.A., Bergman, L.E., Druid, H., Frisén, J.: Forensics: e age written in teeth by nuclear tests. Nature 437(7057) (2005) 333–334\n"
"145. Lovecraft, H.P.: HP Lovecraft: Tales: Tales. Library of America (2005)\n"
"146. Duncan, R.: A survey of parallel computer architectures. Computer 23(2) (1990) 5–16\n"
"147. Santos, N., Hoshino, Y.: Global distribution of rotavirus serotypes/genotypes and its implication for the development and implementation of an effective rotavirus vaccine. Reviews in medical virology 15(1) (2005) 29–56\n"
"148. DIARRHOEA, R.: Rotavirus and other viral diarrhoeas. Bulletin of the World Health Organization 58(2) (1980) 183–198\n"
"149. Barton, T.: Power and knowledge: astrology, physiognomics, and medicine under the Roman Empire. University of Michigan Press (2002)\n"
"150. Gauquelin, M.: The cosmic clocks: From astrology to a modern science. H. Regnery Company (1967)")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")