#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[a-z]\..*$"
Local $sString = "Instead of strings like " .*(?=\.)"" & @CRLF & _
"Lets have:" & @CRLF & _
"matchCriteria:" & @CRLF & _
"..... str from source" & @CRLF & _
"..... where" & @CRLF & _
"..... str startswith Text.Anything" & @CRLF & _
"# until one before period" & @CRLF & _
"..... until (source endswith Chars.Period) - 1" & @CRLF & _
"" & @CRLF & _
"Possibly a markup language (RegXML) that will store RegExp information for SOA messaging." & @CRLF & _
"" & @CRLF & _
"And a search tool for the desktop and for the web, with a WYSIWYG regexp editor that works as follows on any text:" & @CRLF & _
"" & @CRLF & _
"a. Load sample or text to search." & @CRLF & _
"" & @CRLF & _
"b. Mouse over and mark the words or "sections" you are intending to search for inside the text." & @CRLF & _
"" & @CRLF & _
"c. As you mark, each section is given its definitions: if its from the beginning or till the end of a word it will give the possible [b]Word (starting/ending/exactly) with markedword[b]." & @CRLF & _
"" & @CRLF & _
"d. When standing on a section, you can mark it as being a "formatted text" or other. (if the section has slashes, hyphens and periods etc, it will suggest this automatically)." & @CRLF & _
"" & @CRLF & _
"e. Famous formats can be chosen and automatically detected." & @CRLF & _
"" & @CRLF & _
"For example: Search for format of date: where day is: (any/between/less than) etc." & @CRLF & _
"" & @CRLF & _
"f. Didn't think out the REPLACE functionality yet."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")