#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b[a-fA-F0-9]{32,128}\b"
Local $sString = "MD5 Hashes:" & @CRLF & _
"" & @CRLF & _
"dfbf02e00c4bc7c737a4479a6bcc2662" & @CRLF & _
"78fd94b5de88a8c32a1521a9edf3f908" & @CRLF & _
"d1dfaf1d502252eede2b4d492e990be0" & @CRLF & _
"4a6d82b24008d338941a1a7f9369742d" & @CRLF & _
"9ec1730ec98c161360b13aae5d46ad12" & @CRLF & _
"SHA1 Hashes:" & @CRLF & _
"" & @CRLF & _
"82ad7d8314ed1a73dac3de38970d8717e9923e26" & @CRLF & _
"ddda41e9fcec08e0feb68629b57cbe06ce12ac16" & @CRLF & _
"68b7122f58f0cdb3b20e1f3eac1fed6e1036061b" & @CRLF & _
"634dbc333d264f22c02402fc568d4a5cd3bb3b0e" & @CRLF & _
"74af0c22f50e4c4c1b1dead321649e6022a2ac24" & @CRLF & _
"SHA256 Hashes:" & @CRLF & _
"" & @CRLF & _
"a734caac2c040c629ff86b87163eb92f2ec124f95a3f3ecd0530db7159bc404a" & @CRLF & _
"b75c5c00b9e1b93c7cb63eab0266ade210b5e537c4374cedafb9f30569cc2202" & @CRLF & _
"afa97cbdfd095037792305bcc0a63e07df645d7540c94ec73f7954595336992d" & @CRLF & _
"f67ac28d075c22db46fba3f400fabe820194dc85280d06c7d16326c88a31f7f8" & @CRLF & _
"f6e99ce69331f6aa18a34d59aec33fb59abfdda8ee381406245ef727dd96d45b" & @CRLF & _
"SHA512 Hashes:" & @CRLF & _
"" & @CRLF & _
"cc05fe2373f2750aa969d2cb73b9e9db5550091400df6bef1d17c2e03df5b4531964b70ef84bcc8e3aae7d931fc53695f9642bc1480a00b75f669fc4025fb41f" & @CRLF & _
"13d23518b639548b29a86caf178d2042ccd7983c7197368a25e077c4706c38752272f3f4a49e6d9738358d6a2a04b253f7996c8633d4fd4ac17980455a32dc5e" & @CRLF & _
"0871723a28839c68b0c4c0212a8877b461226c7a4e060f108fc33ef8c95db7b2c21a01e8943880f63f68276ccc82c4f28d1e0ef77ae4f9d1393b2097465d42b9" & @CRLF & _
"ea0b231c71ee9433ba16a0445fbff1c37885753d3f0fe6b80be56f50956cc43b6cbef8786ce80899afb1577012c211f675cae57348b8d6a290a8baed227dacdd" & @CRLF & _
"81bf9797ebcabafc3e9dffa7cf8d65f1cf76a41f49b5980db528abbb54c132c5407ba60a7d6256db8e20fe58508296188bf6ccc84331bbcedd9b5cafe77e5e62"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")