re = /^(\+\d{1,2}\s)?\(?\d{3}\)?[\s.-]?\d{3}[\s.-]?\d{4}$/m
str = '843-626-0302
785-333-8041
863-587-8815
658-875-1516
580-449-7703
962-731-8512
878-924-0235
756-713-2113
888-923-3435
308-586-0293
598-683-0441
675-628-3515
209-797-3451
771-440-4352
193-953-1253
(253) 6509483
(347) 8127332
(754) 7719425
(213) 5265535
(402) 1977514
(735) 7162662
(676) 9793937
(611) 4247674
(604) 2130247
682 207 3739
357 908 6923
493 219 9082
980 154 6402
294 121 8026
561 255 8516
477 860 5769
776 644 9851
509 625 7679
+48 793 766 3373
+86 806 716 0094
+86 585 664 5867
+62 737 389 6574
+420 222 563 6738
+7 260 995 8947
+993 171 621 0950
+62 646 616 4139
+98 714 968 6953
+212 967 232 9606
+7 (748) 109-5579
+98 (333) 697-0263
+86 (668) 939-6348
+56 (397) 682-4831
+86 (907) 582-5004
+86 (808) 602-5582
+86 (601) 453-7045
+86 (176) 350-1980
+57 (982) 617-5389
+7 (384) 102-7843
+66-226-146-9224
+972-270-501-4701
+86-865-794-9776
+66-237-386-9139
+62-104-622-7544
+856-256-504-8882
+1-882-964-4797
+33-602-657-9024
+60-548-777-0851
+86-982-155-6812
386(570)720-5471
1(585)244-8353
244(462)323-3908
381(383)564-2517
55(239)311-9045
86(684)401-0051
82(252)838-5913
233(739)838-8421
1(869)479-5451
53(687)450-7439
62(885)232-9247
5038954693
5523566227
2835852181
4871138589
6604677771
5814400542
1149880242
8619976834
5985388913
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end