$re = '~\b\w+\b(?=\W*wp78de)~';
$str = 'Berlin wp78de Tokio
Paris London wp78de
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);