$re = '/^\+?6?(?:01[0-46-9]-?(?:\d{7,8}|\d{4} \d{4})|0\d-\d{3} \d{4})$/m';
$str = '012-1234567
012-1234 5678
09-123 1234
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);