// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)packages/(?<package>[^\/]+)/(?<version>[^\/]+)/(?<file>[^\/]+)").unwrap();
let string = "packages/a-bc/1.0.0b2414.dev7+fde6133/a.bc-1.0.0b2414.dev7+fde6133-py3-none-any.whl
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}