# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^[1][2][3][4-9]$|^[1][2][4-9][0-9]$|^[1][3-9][0-9][0-9]$|^[2][0-2][0-9][0-9]$|^[2][3][0-3][0-9]$|^[2][3][4][0-5]$"
test_str = ("1233\n"
"1234\n"
"1343\n"
"1500\n"
"1234\n"
"2332\n"
"2340\n"
"2345\n"
"2346\n\n"
"READABLE\n"
"^[1][2][3][3-9]$|\n"
"^[1][2][4-9][0-9]$|\n"
"^[1][3-9][0-9][0-9]$|\n"
"^[2][0-2][0-9][0-9]$|\n"
"^[2][3][0-3][0-9]$|\n"
"^[2][3][4][0-5]$")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.