package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`((\d{4})-(\d{2})-(\d{2})) ((\d{2}):(\d{2}):(\d{2}))`)
var str = `2020-05-10 20:23:05`
var substitution = "日期\1 时间\5 \2年\3月\4日 \6时\7分\8秒"
fmt.Println(re.ReplaceAllString(str, substitution))
}