package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`I have a .*?`)
var str = `I have a cat`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}