$re = '/\@[^\#\@\n]+?(?= *[\#\@\n]|$)/m';
$str = 'text = VLOG - Primer evento de la temporada #ModaenTiktok #eventotiktok #madrid @Tik Tok españa
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);