package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\(.*\)`)
var str = `Text1 (Text2) Text3`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}