re = /\w+(?=[^{}]*})/m
str = 'actionname {componentOne, componentTwo, componentThree}
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end