$re = '/^[0-9.|]{8,10}-[Kk0-9]$/m';
$str = '10.000.000-0
9.343.154-K
17.878.335-2';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);