re = /\|\s*(\w+)(?=\s*\|)/m
str = 'The | community | office | system | is here to help you with specific coding, algorithm, or language problems.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end