import Foundation
let pattern = #"""
^
([^\|]+?)(?:\|\1)*
(\|(?!\1)[^\|]+?)?(?:\|\1|\2)*
((?!\|\1|\2)\|[^\|]+?)?(?:\|\1|\2|\3)*
((?!\|\1|\2|\3)\|[^\|]+?)?(?:\|\1|\2|\3|\4)*
((?!\|\1|\2|\3|\4)\|[^\|]+?)?(?:\|\1|\2|\3|\4|\5)*
((?!\|\1|\2|\3|\4|\5)\|[^\|]+?)?(?:\|\1|\2|\3|\4|\5|\6)*
$
"""#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .allowCommentsAndWhitespace])
let testString = #"""
TPL1
TPL1|TPL1
TPL2
TPL1|TPL2
TPL2|TPL2|TPL1
TPL1|TPL2|TPL1
TPL2|TPL2|TPL2
TPL2|TPL2|TPL2|TPL1|TPL1
TPL2|TPL1|TPL3|TPL2|TPL2|TPL1|TPL1|TPL3|TPL3
TPL1|TPL1|TPL2|TPL2|TPL2|TPL3|TPL3|TPL3|TPL3|TPL1|TPL1
TPL1|TPL1|TPL1|TPL2|TPL2|TPL2|TPL3|TPL3|TPL3|TPL4|TPL4|TPL4|TPL5|TPL5|TPL5|TPL6|TPL6|TPL6
TPL1|TPL6|TPL1|TPL2|TPL2|TPL5|TPL2|TPL3|TPL1|TPL3|TPL4|TPL4|TPL5|TPL3|TPL5|TPL6|TPL4|TPL6
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1$2$3$4$5$6"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)