$re = '/(?<!-)\s*people(?!-)/m';
$str = 'people cars trees people trees people
cars no-people trees
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);