$re = '/(?=[^\s,])(\+?\d(?:[\d\s]*\d)?)?(?:(?:,\s*)?(\S+@\S+)\b)?(?:(?:,\s*)?(www\.\S+)\b)?/m';
$str = '+35 00000000, info@company.com, www.company.com
+35 00000000, +360000000, info@company.com, www.company.com
info@company.com, www.company.com
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);