const regex = /^f( (\d+)(\/{0,2})(\d*)(\/{0,2})(\d*)(\/{0,2})){0,3}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^f( (\\d+)(\\\/{0,2})(\\d*)(\\\/{0,2})(\\d*)(\\\/{0,2})){0,3}$', 'gm')
const str = `f 1 2 3
f 1/ 2/ 3/
f 1// 2// 3//
f 1/1 2/2 3/3
f 1/1/ 2/2/ 3/3/
f 1//1 2//2 3//3
f /1/ /2/ /3/
f 1/1/1 2/2/2 3//3
f 1/1 2/2 3/3 4/4
^f(([ ]\\d{1,2}(\\/{0,2}\\d{0,1})\\/{0,1}){0,3})\$
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}