re = /^([\u00C0-\u017Fa-zA-Z]{2,}(?:[-]?[\u00C0-\u017Fa-zA-Z]{2,}))$/m
str = 'Jay-Dáwg'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end