using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[a-zA-Z0-9\._\-]{1,}@[a-z]{1,}\.[a-z]{2,3}";
string input = @"greg.quer@gmail.fr";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}