$re = '/^(?:\s*|\d+(?:,\s*\d+)*)$/m';
$str = '
10,11,12
10
10, 11, 12';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);