import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "file_path:\\s*\\\"([^\\\"]+)\\\",\\s*text:\\s*\\\"([^\\\"]+)\\\"";
final String string = "file_path: \"hello_world.txt\", text: \"Hello World\"\n"
+ "\"file_path\": \"hello_universe.txt\", \"text\": \"Hello Universe\"";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}