#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\d+\s+(?:BIS|TER|\d*)\s*(?:STREET|AVENUE|BOULEVARD)\s+.*?)\s*(?=(?:\d+|$))"
Local $sString = "THIS IS 24 RUE PIERRE LAPIN 2 AVENUE DES LAPINOUS "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")