using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!(?=(<p\b[^>]*?color\s*:\s*black[^>]*>\s*<span\b[^>]*>\s*|<span\b[^>]*?color\s*:\s*black[^>]*>\s*)))(<code\s*style=""background-color:\s*transparent;"">)";
string input = @"<html>
<p style=""font-family: "verdana"; font-size: 18px; color: black; line-height: 18px; text-align: justify; font-style: normal; font-weight: 400; letter-spacing: normal; orphans: 2; text-indent: 0px; text-transform: none; white-space: normal; widows: 2; word-spacing: 0px; background-color: cyan;""><span style=""font-size: 13.5pt; font-family: "Verdana","sans-serif";""><code style=""background-color: transparent;""><b>some text here</b></code></span></p>
<span><span style=""font-size: 13.5pt; font-family: "Verdana","sans-serif"; background-color: cyan;""><code style=""background-color: transparent;""><b>some text here</b></code></span>
<code style=""background-color: transparent;"">
<p style=""font-family: "verdana"; font-size: 18px; color: cyan; line-height: 18px; text-align: justify; font-style: normal; font-weight: 400; letter-spacing: normal; orphans: 2; text-indent: 0px; text-transform: none; white-space: normal; widows: 2; word-spacing: 0px; background-color: cyan;""><span style=""color: black; font-size: 13.5pt; font-family: "Verdana","sans-serif";""><code style=""background-color: transparent;""><b>some text here</b></code></span></p>
<span><span style=""font-size: 13.5pt; font-family: "Verdana","sans-serif"; background-color: cyan;""><code style=""background-color: transparent;""><b>some text here</b></code></span>
<p style=""font-family: "verdana"; font-size: 18px; color: cyan; line-height: 18px; text-align: justify; font-style: normal; font-weight: 400; letter-spacing: normal; orphans: 2; text-indent: 0px; text-transform: none; white-space: normal; widows: 2; word-spacing: 0px; background-color: navy;""><span style=""font-size: 13.5pt; font-family: "Verdana","sans-serif";""><code style=""background-color: transparent;""><b>some text here</b></code></span></p>
</html>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}