const regex = /(?<!(href="))(?<!(\/\/EN" "))(?<!(xmlns="))(?<!(\* ))(?<!(xmlns:xsd="))(?<!(namespace="))(?<!(itemtype="))http:\/\/+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!(href="))(?<!(\\\/\\\/EN" "))(?<!(xmlns="))(?<!(\\* ))(?<!(xmlns:xsd="))(?<!(namespace="))(?<!(itemtype="))http:\\\/\\\/+', 'g')
const str = `You may also want to exclude searching these files.
-*.po|-*.txt|-*.md|-*.pot|-*.pdf|-*.jpg|-*.png|-*.gif
Note: "|" is used with GrepWin, use "," for Sublime
---
http://
https://
<script src="http://site.com/script.js"></script>
<script src="https://site.com/script.js"></script>
<script>
srcHttp = 'http://mysite.com/custom.js';
srcHttps = 'https://mysite.com/custom.js';
</script>
<a href="http://site.com">link</a>
<a href="https://site.com">link</a>
/*
* http://link.com
* https://link.com
*/
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org...">
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org...">
<html xmlns="http://www.w3.org/1999/xhtml">`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}