using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([^-\n]*-[^=\n]*)-.*$";
string input = @"Tab 3-3-z-o.pdf
Should be Tab 3-3.pdf
Tab 2-3-jk2.pdf
Should be: Tab 2-3.pdf
Tab 3-3-Yuwk-3-k-l-s.pdf
Should be: Tab 3-3.pdf";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}