re = /recepten-zoeken\/([^?]+)\?/
str = 'https://localhost:8443/site/recipes/recepten-zoeken/menugang:hoofdgerecht/soort:italiaans/seizoen:winter?Nrpp=24'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end