$re = '/(\[DLC\])(.*)/m';
$str = 'Hello [DLC] World';
$subst = "$2$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;