$re = '/[^[:alnum:]]+/m';
$str = 'aSe1245 2371';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);