$re = '/(?:red|redb)\.(?:(?<dpi>dpi)|(?<port>port)|fb_width|fb_height)="\K\w+/m';
$str = 'bst.instance.red.port="5555"
bst.instance.red.dpi="240"
bst.instance.red.fb_height="900"
bst.instance.red.fb_width="1600"
bst.instance.red.first_boot="0"
bst.instance.redb.port="2000"
bst.instance.redb.dpi="120"
bst.instance.redb.fb_height="300"
bst.instance.redb.fb_width="800"
bst.instance.redb.first_boot="0"
bst.instance.redc.port="2000"
bst.instance.redc.dpi="120"
bst.instance.redc.fb_height="300"
bst.instance.redc.fb_width="800"
bst.instance.redc.first_boot="0"';
$subst = "${dpi:+YYY:}${port:+WWW:}";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;