const regex = /^-?(((?!0+)1?[0-9]{0,3})|0)(\.[0-9]{1,2})?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^-?(((?!0+)1?[0-9]{0,3})|0)(\\.[0-9]{1,2})?$', 'gm')
const str = `001
01
-0
0
-1
1
10
-10
-1000
-999.99
0001
1000
10000
-1000
0.001
0.01
0.1
0032
1.2
0.2
-0.2
123
100
199
233
459
999
888
-999
-888
-123.21
-021.32
9999
-1.010
01.32
99.99
0
-1.2`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}