# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?P<unit_type>S)(?P<unit_size>6|8|10|15|20|25|30)(?P<mounting_type>A|P)(?P<cracking_pressure>00|02|05|15|30|50|80)(?P<sep_1>-)(?P<unit_series>1X)(?P<sep_2>/|=)(?P<pressure_rating_max>420|450|)(?P<surface_coating>J3|J5|V|)(?P<orifice_position>B|)(?P<orifice_diameter>00|03|05|08|10|12|15|)(?P<pipe_port>/2|/12|)(?P<special_version>(.|[0-9])*)$"
test_str = ("S20P15-1X/\n"
"S30P05-1X/V\n"
"S30P02-1X/V\n"
"S30P15-1X/V\n"
"S30P30-1X/V\n"
"S30P50-1X/V\n"
"S30P00-1X/\n"
"S30P05-1X/\n"
"S30P15-1X/\n"
"S30P30-1X/\n"
"S30P50-1X/\n"
"S10P00-1X/\n"
"S10P05-1X/\n"
"S10P05-1X/V\n"
"S10P15-1X/\n"
"S10P15-1X/V\n"
"S10P30-1X/\n"
"S10P30-1X/V\n"
"S10P50-1X/\n"
"S20P00-1X/\n"
"S20P05-1X/\n"
"S20P05-1X/SO74\n"
"S20P05-1X/V\n"
"S20P05-1X/VSO74\n"
"S20P15-1X/SO74\n"
"S20P15-1X/V\n"
"S20P30-1X/\n"
"S20P30-1X/SO74\n"
"S20P30-1X/V\n"
"S20P30-1X/VSO74\n"
"S20P50-1X/\n"
"S30P05-1X/VSO74\n"
"S30P00-1X/SO74\n"
"S30P15-1X/SO74\n"
"S30P05-1X/SO74\n"
"S25P15-1X/V\n"
"S15P15-1X/V\n"
"S15P15-1X/\n"
"S25P15-1X/\n"
"S10A05-1X/450J3\n"
"S20A05-1X/450J3\n"
"S30P05-1X=V\n"
"S30P50-1X=V\n"
"S10P05-1X=V\n"
"S10P30-1X=V\n"
"S20P05-1X=V\n"
"S15A02-1X/450J3\n"
"S20A02-1X/450J3\n"
"S10A05-1X/450J3/12\n"
"S20A05-1X/450J3B15/12\n"
"S10A15-1X/450J3/12\n"
"S20A30-1X/450J3\n"
"S6A00-1X/450J3\n"
"S6A02-1X/450J3\n"
"S6A05-1X/450J3\n"
"S6A15-1X/450J3\n"
"S6A30-1X/450J3\n"
"S6A50-1X/450J3\n"
"S8A00-1X/450J3\n"
"S8A02-1X/450J3\n"
"S8A05-1X/450J3\n"
"S8A15-1X/450J3\n"
"S8A30-1X/450J3\n"
"S8A50-1X/450J3\n"
"S10A00-1X/450J3\n"
"S10A02-1X/450J3\n"
"S10A02-1X/450J3/12\n"
"S10A15-1X/450J3\n"
"S10A30-1X/450J3\n"
"S10A50-1X/450J3\n"
"S15A00-1X/450J3\n"
"S15A05-1X/450J3B00\n"
"S15A05-1X/450J3\n"
"S15A15-1X/450J3\n"
"S15A30-1X/450J3\n"
"S15A50-1X/450J3\n"
"S20A00-1X/450J3\n"
"S20A02-1X/450J3/12\n"
"S20A05-1X/450J3/12\n"
"S20A15-1X/450J3\n"
"S20A30-1X/450J3/12\n"
"S20A50-1X/450J3\n"
"S25A00-1X/420J3\n"
"S25A02-1X/420J3\n"
"S25A05-1X/420J3\n"
"S25A15-1X/420J3\n"
"S25A30-1X/420J3\n"
"S25A50-1X/420J3\n"
"S25A80-1X/420J3\n"
"S30A00-1X/420J3\n"
"S30A02-1X/420J3\n"
"S30A05-1X/420J3\n"
"S30A15-1X/420J3\n"
"S30A30-1X/420J3\n"
"S30A50-1X/420J3\n"
"S30A80-1X/420J3\n"
"S8A00-1X/450J3/12\n"
"S8A05-1X/450J3/12\n"
"S8A15-1X/450J3/12\n"
"S8A30-1X/450J3/12\n"
"S10A00-1X/450J3/12\n"
"S10A30-1X/450J3/12\n"
"S10A50-1X/450J3/12\n"
"S15A00-1X/450J3/12\n"
"S15A02-1X/450J3/12\n"
"S15A05-1X/450J3/12\n"
"S15A15-1X/450J3/12\n"
"S15A30-1X/450J3/12\n"
"S15A50-1X/450J3/12\n"
"S20A00-1X/450J3/12\n"
"S20A15-1X/450J3/12\n"
"S20A50-1X/450J3/12\n"
"S25A00-1X/420J3/12\n"
"S25A02-1X/420J3/12\n"
"S25A05-1X/420J3/12\n"
"S25A15-1X/420J3/12\n"
"S25A30-1X/420J3/12\n"
"S25A50-1X/420J3/12\n"
"S30A00-1X/420J3/12\n"
"S30A02-1X/420J3/12\n"
"S30A05-1X/420J3/12\n"
"S30A15-1X/420J3/12\n"
"S30A30-1X/420J3/12\n"
"S30A50-1X/420J3/12\n"
"S10A05-1X/450J3B08\n"
"S10A05-1X/450J3B15\n"
"S25A15-1X/420J3B10\n"
"S25A50-1X/420J3B00\n"
"S10A05-1X/450J3B00\n"
"S20A05-1X/450J3B00\n"
"S30A05-1X/420J3B00\n"
"S30A05-1X/420J3B10\n"
"S30A80-1X/420J3B12\n"
"S15A05-1X/450J5/12\n"
"S8A05-1X/450J3B03\n"
"S30A50-1X/420J3B12\n"
"S10A05-1X/450J3B10\n"
"S30A30-1X/420J3B12\n"
"S25A30-1X/420J3B12\n"
"S15A05-1X/450J5\n"
"S15A05-1X/450J5/12=AH\n"
"S8A05-1X/450J3B08\n"
"S10A05-1X=450J3\n"
"S25A00-1X/420J3B10\n"
"S10A05-1X/450J3B12\n"
"S30A05-1X=420J3\n"
"S10A50-1X/450J3/2\n"
"S8A05-1X/450J3B05\n"
"S15A50-1X/450J5\n"
"S10A05-1X/450J3B10/12\n"
"S25A50-1X/420J3B10\n"
"S15A05-1X/450J3/2\n"
"S15A05-1X/450J3B10\n"
"S20A05-1X/450J3B10\n"
"S25A05-1X=420J3/12\n"
"S8A50-1X/450J5\n"
"S8A05-1X/450J3B00\n"
"S15A05-1X=450J3\n"
"S25A05-1X=420J3\n"
"S20A05-1X/450J3B15\n"
"S6A05-1X=450J3\n"
"S15A30-1X/450J3B10\n"
"S20A05-1X/450J5\n"
"S20A30-1X/450J3B15\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.