# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
^(>*([=*_]) # Match a separator type and put it in group 2, group 1 will contain the whole seperator so that we can "backreference" it in the closing tag
\2{3} # It needs to be at least 4 long let's say (1 + 3)
(?:\2|[\r\n])+) # Let's now support also newlines for "multi line seperators"
([\s\S]+?) # Match the content and put it in group 3
\1
"""
test_str = ("This is some text that should not be matched. As you can see, it is not enclosed\n"
"by separator lines.\n\n"
"===========================================================\n"
"This part should be matched as it is between two separator lines. Note that the\n"
"opening and closing separators are composed of the exact same number of the same\n"
"character.\n"
"===========================================================\n"
"This block should not be matched as it is not enclosed by its own separators,\n"
"but rather the closing separator of the previous block and the opening \n"
"separator of the next block.\n"
"===========================================================\n"
"It is tricky to distinguish between an enclosed and non-enclosed blocks, because\n"
"sometimes a matching pair of separators appears to be legal, while it is really\n"
"the closing separator of the previous block and the opening separator of the\n"
"next one (e.g. the block obove this one).\n"
"===========================================================\n"
"==================================\n"
"=====\n"
"This block is enclosed by multiline separators.\n"
"==================================\n"
"=====\n"
"Some more text that should not be matched by the regex.\n"
"***************************************\n\n\n\n"
"A separator can be a different character, for example the asterisk.\n\n\n"
"***************************************\n"
"***************************************\n"
"*******************\n"
"Another example of a multiline separated block.\n"
"***************************************\n"
"*******************\n\n"
">Even more text not to be matchedby the regex. This time, preceeded by a\n"
">variable number of '>'.\n"
">>__________________________________________\n"
">>And another type of separator. The block is now also a part of a reply section\n"
">>of the email.\n"
">>__________________________________________")
matches = re.finditer(regex, test_str, re.MULTILINE | re.VERBOSE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.