$re = '/\w+ ?\+ ?\w+/';
$str = 'tree + bowl
flower+sun
disk+ drive
large +database';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);