package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\w+ *\+ *\w+`)
var str = `tree + bowl
flower+sun
disk+ drive
large +database`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}