$re = '/^[^#][A-z][A-z\d]+/m';
$str = 'oz5566 #1Ykfc0LK 未滿15字';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);