re = /#(\S+'[\S\s]+'|\S+)/m
str = '#343242 #4#32# #4 #ödgködg #Hello:\'klf ködsf\' kmfsdölfgölkamsf löj'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end