import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^AB ([\\s\\S]*?)(?=\\n[A-Z]{2}\\s)";
final String string = "TI TEST TEST TEST TEST TEST TEST TEST TEST AJSAOISJAO SOAI\n"
+ " ASASPAOS\n"
+ "SO EITCHA EITCHA EITCHA EITCHA EITCHA EITCHA EITCHA EITCHA \n"
+ "AB Purpose\n"
+ " To examine the evidence supporting the use of simulation-based assessments as surrogates for patient-related outcomes assessed in the workplace.\n"
+ " Method\n"
+ " The authors systematically searched MEDLINE, EMBASE, Scopus, and key journals through February 26, 2013. They included original studies that assessed health professionals and trainees using simulation and then linked those scores with patient-related outcomes assessed in the workplace. Two reviewers independently extracted information on participants, tasks, validity evidence, study quality, patent-related and simulation-based outcomes, and magnitude of correlation. All correlations were pooled using random-effects meta-analysis.\n"
+ " Results\n"
+ " Of 11,628 potentially relevant articles, the 33 included studies enrolled 1,203 participants, including postgraduate physicians (n = 24 studies), practicing physicians (n = 8), medical students (n = 6), dentists (n = 2), and nurses (n = 1). The pooled correlation for provider behaviors was 0.51 (95% confidence interval [Cl], 0.38 to 0.62; n = 27 studies); for time behaviors, 0.44 (95% Cl, 0.15 to 0.66; n = 7); and for patient outcomes, 0.24(95% Cl, 0.02 to 0.47; n = 5). Most reported validity evidence was favorable, though studies often included only correlational evidence. Validity evidence of internal structure (n = 13 studies), content (n = 12), response process (n = 2), and consequences (n = 1) were reported less often. Three tools showed large pooled correlations and favorable (albeit incomplete) validity evidence.\n"
+ " Conclusions\n"
+ " Simulation-based assessments often correlate positively with patient-related OI outcomes. Although these surrogates are imperfect, tools with established validity evidence may replace workplace-based assessments for evaluating select procedural skills.\n"
+ "OI MANEIRAO MANEIRAOMANEIRAOMANEIRAO MANEIRAO\n"
+ "SN 6516516516\n"
+ "EI 849819981981\n"
+ "PD FEB\n"
+ "PY 2015";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}