re = /^(?:\+\d(?:\(\d{3}\)(?:-\d{3}-|\d{3})|\d{6})|\d{6})\d{4}$/m
str = '9999999999
+19999999999
+1(999)9999999
+1(999)-999-9999'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end